Dashboard unavailable due to upstream provider outage

Incident Report for CipherStash

Resolved

Dashboard is now available, and the upstream provider has resolved their outage.
Posted Dec 05, 2025 - 09:25 UTC

Investigating

dashboard.cipherstash.com is currently unavailable.

CTS and ZeroKMS are still fully operational.

We are monitoring the situation and will post updates at least every 30 minutes.
Posted Dec 05, 2025 - 09:16 UTC
This incident affected: Dashboard.