Website and dashboard network routing outage due to upstream provider

Incident Report for CipherStash

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 19:47 UTC

Monitoring

We are seeing recovery in specific locations around the globe and are monitoring the issue.
Posted Nov 18, 2025 - 15:03 UTC

Identified

The CipherStash website, documentation, and dashboard are currently unavailable due the Cloudflare global network outage. We have identified the issue.
Posted Nov 18, 2025 - 14:21 UTC
This incident affected: Dashboard.